Sign in to follow this  
Juicehead99

Anybody help diagnose this please?

Recommended Posts

Dash clocks have a delay when i turn ignition on, take about 10 seconds to come to life once i turn kwy to ignition position, whether i start car or not its same amount of time every time from when ignition position is on.

Just replaced battery, alternator and battry fuse after having issues

Mk6 fiesta 1.4 petrol.

 

Share this post


Link to post
Share on other sites

Ive done all earth'sunder bonnet,

may it be an earth in dash?

 

Ive had to use my audio fuse to replace my battry fuse as i had none one me,

Could the no fuse in audio slot cause if  its not a full circuit?

Share this post


Link to post
Share on other sites

My bro mk6 1.25 is the same needles like shake a bit like a few second delay and also he's mpg always resets

Share this post


Link to post
Share on other sites

There is no shaking. It is just a delay till they move from the bottom up to idle level 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this