Sign in to follow this  
Cluelesss

Stupid question - first service

Recommended Posts

So I've had my Red Edition Fiesta for little over a year now and done 8k miles. It's obviously now due its first service which will be arranged shortly but the service indicator light hasn't come on, is this normal? Does it only come on after you've done the mileage interval?

Cheers

Share this post


Link to post
Share on other sites

I've got the same car and never noticed this? Unless it only comes on of there's something wrong with your car

Share this post


Link to post
Share on other sites

If your past a year don't leave it to long to make sure you maintain the warranty

Share this post


Link to post
Share on other sites

sure someone will correct me but I believe it must be done within 30 days of first registration date anniversary to maintain warranty

Share this post


Link to post
Share on other sites

I don't think Fiesta has service indicator.

Share this post


Link to post
Share on other sites

Mine does (Mk 7.5).  Think it's set on mileage 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this