Sign in to follow this  
Metalzone

Sync 3 3.0v, Climate on Touch Screen and ST Splash Screen

Recommended Posts

Happy New Year to all !

 

I have updated my Sync version to 3.0 17194.

Add climate control to the touch screen and gain voice control of the temperature setting:
Made the following change to the Apim module(credit to Livnitup) 

C7D0-01-02 xxxx x2xx xxxx
and 1 of the following:
7D0-01-01 xxxx xxx3 xxxx - Dual Zone & HD radio avail   (this one worked for me)
7D0-01-01 xxxx xxx2 xxxx - Dual Zone & HD radio not avail

Climate Contro Touch Screen.JPG

Climate Home Screen.JPG

Changed the splash screen logo from Ford classic logo to ST Performance logo:

By changing the Apim module line :

7D0-02-01 xxxx xXxx xxxx (sorry, don't remember who's credit is...)

ST Splash Screen.JPG

Apim Module AS Built Factory.jpg


I am very pleased with the changes, but, got a negative side effect, now i have on the touch screen the correct distance information to turns and so on, but the screen on the instrument cluster shows a wrong distance. I took the fotos below on the same place of the trip so you can see the diferente information. Any idea what cause this? Shouldn't it be displayed the same information, does it not have the same source? How to solve it?

 

Correct Distance Touch Screen.JPG

Wrong Distance Instrument Cluster.JPG

 

Share this post


Link to post
Share on other sites

Not sure on your problem but have you tried a master reset ?

 

Also when you added climate have you noticed that when you turn the dial on the manual climate control it alters the opposite temp reading on the touch screen ?

 

Share this post


Link to post
Share on other sites

No i did not tried a master reset.

My factory version of Sync 3 was the 2.2v, will the 3.0v be downgraded to 2.2v with the master reset?

The climate control on the touch screen and the ST splash screen logo will be gone after the master reset or as they were changed to the apim module, will they stick? 

The controls work as they should, turning the right dial changes the right side of the vents and display it correctly.

 

 

 

Share this post


Link to post
Share on other sites

Disconnected battery cable, did a master reset, all remains the same:

Sync 3 version continues to be 3.0

Climate control and ST logo remais on the touch screen.

Still displaying different distances between touch screen and the instrument cluster's screen ...

Any idea of what's causing this?

 

18 hours ago, Tezza said:

Also when you added climate have you noticed that when you turn the dial on the manual climate control it alters the opposite temp reading on the touch screen ?

 

Re-checked this morning, all doing as suppose regarding knob and touch screen controls.

 

Share this post


Link to post
Share on other sites
19 hours ago, Metalzone said:

7D0-02-01 xxxx xXxx xxxx

This how is should be: 7D0-02-01 xxxx xBxx xxxx

Share this post


Link to post
Share on other sites

39 minutes ago, Metalzone said:

This how is should be: 7D0-02-01 xxxx xBxx xxxx

So xxxx xBxx xxxx     B being a letter no 8 a number  and this is to enable ST splash screen 

Share this post


Link to post
Share on other sites
5 hours ago, Tezza said:

So xxxx xBxx xxxx     B being a letter no 8 a number  and this is to enable ST splash screen 

That is correct. If you have the classic Ford logo you should have a 1, and you have to replace it with the letter B. 

Share this post


Link to post
Share on other sites

Just a word of advice when doing this. If you get any issues with the car Ford can and will void your warranty if they notice you've been messing around with values. Whether its entirely true or not but my dealer said that data from your car that they need to take to diagnose an issue goes back to Ford in Chicago USA and they will be able to see values have been changed.

Share this post


Link to post
Share on other sites

I´m sure they will, let´s hope nothing get's bricked :ph34r:. That´s one concern to keep in mind when doing these changes to a car with 7 year warranty, in my case.

I just had to have Cruise Control, bought the St Line with the assumption that it has CC factory fitted, as the entry level os Focus here in Portugal has it. At least, Ford changed the way the different versions of Focus are displayed on the web site and catalogue . They had it displayed just before the ST. Usually, the first version has the main characteristics displayed and all the other have the same, plus the specific ones. As the St Line was between the Titanium and the ST... This is why i started to make these changes.  

Long story short, and to prove your point, i have this discrepancy of distances between the touch screen and the screen on the instrument cluster and i can't complain about it :ohmy:  

I can not figure out why two completely different values are displayed! Any guess why?

Is there a different module to the Instrument cluster that needs any update?

  

Share this post


Link to post
Share on other sites

By wondering around others fóruns, i came across with the information that to retrofit Satnav and displaying it in the instrument cluster, a hex line code have to be changed, one of the lines i changed to get climate control on screen. So, i ended up returning to factory hex code in those specific lines and got back accurate and matching distances on both screens.

I made these changes to the hex lines:

First attempt: 7D0-01-02 xxxx x2xx xxxx + 7D0-01-01 xxxx xxx3 xxxx - Dual Zone & HD radio avail
Second Attempt: 7D0-01-02 xxxx x2xx xxxx + 7D0-01-01 xxxx xxx2 xxxx - Dual Zone & HD radio not avail 

Both made the climate work great, but, messed with the displayed distances, wich i believe means that only a slight change has to be done.

Does anyone knows the right codes? 

 

Share this post


Link to post
Share on other sites

After some digging, thanks to murat_kavuk at the Forscan forum, found the codes that make it work:

7D0-01-02: xxxx x3xxx xxxx - Climate button + climate voice control
7D0-04-01: xxxx xxx0 xxxx - To see set temperatures on main screen (shortcut to climate setting window is climate button enabled)

All seems to work right, touch screen controls, knobs, temperature voice control, correct and matching distances at both screens.

As written in the second code, it displays driver's and passenger side temperatures, when changing the temperature in a menu diferente than climate, will show on screen a pop up just like the one that appears when changing volume.

This time, i tested every thing i could think of, it all worked just fine.

Climate.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this