Jump to content
Do Not Sell My Personal Information


Windscreen washers


Bobr
 Share

Recommended Posts

One of the jets on the driver's side is blocked.   I've tried pushing a small needle through the jet and it goes through OK but has made no difference. Anyone know how I can unblock it?

Link to comment
Share on other sites


Have you tried disconnecting the washers and tubing under the bonnet and checking that there isn't a blockage in the tubing?

If the washers are still possibly the source of the blockage, have you got any compressed air that you could try blasting in through either end? Only other thing I can think of is to try and put the washers into some hot water if the blockage is something that might dissolve.

Link to comment
Share on other sites

Lift the bonnet and the jets have a clip on the underside that you can simply squeeze to get the washer jets to lift out. You will obviously need to disconnect the tubing before.

Link to comment
Share on other sites

Can't get at the washer jets as there's some sort of matting attached to the underside of the bonnet and it covers them.   Seems to be attached with some round things.

Link to comment
Share on other sites

Ah, yes, forgot that there is the soundproof matt. The clips just pull out (about 8 of them if I remember). A flathead screwdriver or metal ruler to get underneath them might help and a little bit of elbow grease and they should come out. Simply push them back in when you're fitting everything back.

Link to comment
Share on other sites

Always the way 😀.

I did have several photos for when I changed my washers in the past but I can't find the post on the forums and the original photos are on an old PC that is not accessible at the moment.

Link to comment
Share on other sites

Did the job this morning and, eventually, managed to convince the jets that they had to come out. When they did, they shot out, bounced off the windscreen and fell into the engine bay.

I eventually found them and gave them a thorough seeing to with a fine needle and got them spraying perfectly. Unfortunately, when they were refitted and everything put back together, they were back to only one jet working. Cannot understand that.

I’m going to get some new jets and fir them Many thanks for your instructions.

Link to comment
Share on other sites

Sounds like a faff.

You've lost me where you say you got them spraying perfectly but when refitted only one jet worked. Did you re-connect them before fitting them back in the bonnet to test?

Have you checked that the tubing isn't blocked or kinked?

Link to comment
Share on other sites

Before I refitted them I reconnected the tubing and tested them and the both sprayed perfectly.   After I had refitted them the left one appeared to be blocked again and the right one sprayed over the roof.   Can't explain it.   I'm off to Halfords this afternoon as I've spoken to a guy there and he says they got some that will do the job.

Link to comment
Share on other sites

I could probably just give you my original washer jets seeing as I have two sets of mist washers. I haven't a clue where they are at the moment but they will be in a box/tub somewhere here 😀

Link to comment
Share on other sites

@Zico Talking about jets, have you got the ones that came off the Focus?  If so, is there any way you are able to adjust them?  They hit the screen, but rather majestically they hit the roof, bonnet, and both side windows as well and that's a giant pain.

 

J

Link to comment
Share on other sites

Yes, I have the Focus mist jets on my ST but the only thing I have read about adjusting where the spray goes is by using a bit of glue/blutack in the slot. Can't remember where I have read this but haven't done so myself as I don't find the spray to be an issue.

**Edit** Found this thread if it's any help:

 

Link to comment
Share on other sites

42 minutes ago, Zico said:

Yes, I have the Focus mist jets on my ST but the only thing I have read about adjusting where the spray goes is by using a bit of glue/blutack in the slot. Can't remember where I have read this but haven't done so myself as I don't find the spray to be an issue.

Possibly was read here mate 

Guide to Fitting New Ford Mist Type Jets on all Models Click Here  

Remember reading about that myself

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership