Orianna40

Ford focus Climate 1.6 whining sound from fuse box

Recommended Posts

Hi all I am praying someone can give me some advice . 

I have a focus climate 1.6 2005 and for a while it made an odd sound just before if started when I turned the key ..almost a clicking noise from over by the battery /fusebox direction but today I was about to go to the hospital and it didnt do anything when I turned the key apart from make a strange whining sound from the fuse box by the passenger side . My husband managed to look at the fuses by the battery and said he thought one looked wet and when he looked at the one by the passenger side he said the whirring sound was coming from inside a sealed bit on the fuse box (under a sticker )   there is no way we can afford to take it to the Ford garage as I am on disability so just dont have the money but I'm really worried as I need the car to get around.  Does anyone have any idea of the cause and the estimated cost of repair please.  It  only has 50k miles on the clock and sails through MOT normally. Thankyou to all that read and respond.

Amanda 

Share this post


Link to post
Share on other sites

It sounds like it may just be the starter motor and unrelated to the fusebox.  If you're parked on a hill you could try bump starting it.  The clicking is the starter solenoid trying to engage, it usually happens with a low battery but if it's been happening a while and you've been driving the car like that I'd suggest it's the starter at fault rather than the battery.

Does the dash all light up as you'd expect?  Does the red immobiliser light keep flashing quickly when you turn the key?

Share this post


Link to post
Share on other sites
10 hours ago, TomsFocus said:

It sounds like it may just be the starter motor and unrelated to the fusebox.  If you're parked on a hill you could try bump starting it.  The clicking is the starter solenoid trying to engage, it usually happens with a low battery but if it's been happening a while and you've been driving the car like that I'd suggest it's the starter at fault rather than the battery.

Does the dash all light up as you'd expect?  Does the red immobiliser light keep flashing quickly when you turn the key?

Thank you for your reply .I will get hubby to check all that today when home from work. Many thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.