Danielg19

Fiesta 2003 1.4 semi auto juddering

Recommended Posts

Hi everyone

 

im looking for abit if help with my fiesta 1.4 2003 , couple months back I had severe intermittent juddering as if it was going to stall then engine light came on with a code saying cylinder 4 misfire  Checked the spark plugs to find they were rusty and sitting in water , changed the plugs and the car was fine for few weeks then started again after heavy rain . Noticed the water was getting in through the water jet on driver side and running down airbox and sitting straight on top the ht leads, dried the plugs again and fixed the leak but I’m still having issue with juddering and power loss. If I approach a round about say in 2nd gear then put my foot down I get a judder like kangaroo hopping until I floor it and it pulls away. Sometimes I start it and feels fine can be driving no issue and feels like it’s got the usual power then sometimes it just feels lumpy and no power, it also seems to do most of the juddering when I’m doing a right turn which is bamboozling me. I can only think it still has water in the wells and when I turn it’s moving the water and knocking plug off. I haven’t had any dash lights since. 

 

I was reading a MAF sensor can also cause juddering but I can’t see one on my fiesta and some people say I have a MAP sensor on mine not and airflow sensor ? 

Anyone had same issues or any idea what else can cause this judder, loss power ?

 

Share this post


Link to post
Share on other sites
36 minutes ago, Danielg19 said:

Hi everyone

 

im looking for abit if help with my fiesta 1.4 2003 , couple months back I had severe intermittent juddering as if it was going to stall then engine light came on with a code saying cylinder 4 misfire  Checked the spark plugs to find they were rusty and sitting in water , changed the plugs and the car was fine for few weeks then started again after heavy rain . Noticed the water was getting in through the water jet on driver side and running down airbox and sitting straight on top the ht leads, dried the plugs again and fixed the leak but I’m still having issue with juddering and power loss. If I approach a round about say in 2nd gear then put my foot down I get a judder like kangaroo hopping until I floor it and it pulls away. Sometimes I start it and feels fine can be driving no issue and feels like it’s got the usual power then sometimes it just feels lumpy and no power, it also seems to do most of the juddering when I’m doing a right turn which is bamboozling me. I can only think it still has water in the wells and when I turn it’s moving the water and knocking plug off. I haven’t had any dash lights since. 

 

I was reading a MAF sensor can also cause juddering but I can’t see one on my fiesta and some people say I have a MAP sensor on mine not and airflow sensor ? 

Anyone had same issues or any idea what else can cause this judder, loss power ?

 

have you checked the condition of your engine core plugs?

Share this post


Link to post
Share on other sites
2 hours ago, Martin-Fiesta-MK6-1.4 said:

have you checked the condition of your engine core plugs?

Hi

i haven’t yet , I’m taking it on Saturday to my brothers who is abit better with repairs then me to have a look at it. I haven’t heard of core plugs before , I’ll have a google see what they are and located thanks

Share this post


Link to post
Share on other sites

I took the ht leads out had a look no moister on the leads or I could see just rusty and core plugs rusty, I took the sensor off that I was told could cause issue and it was abit dirty with oil so cleaned it and put back on but same issue , car very sluggish, doesn’t seem conftable in third and wants to sit in 2nd revs jumping.it seems like same issue when I had the plug issue on cylinder 4 but not getting any warning lights 

90857D6E-35B6-43FC-9753-BA93A232D9B2.jpeg

F7C13AC6-2DD3-432C-9835-1D7D975C0D2E.jpeg

2ED1A8D5-A238-4E4D-BEC0-D3C2F37FF743.jpeg

Share this post


Link to post
Share on other sites

Just update , had somebody look at the car they said the drive shaft both sides have allot of play on them and need changed , also I was advised fuel filter should be changed hasn’t been changed in 4 years :/ . I’m going to do full service kit on it oil, filter fuel , new plugs , also change the drive shafts. Does anyone know what else could cause a judder when accelerating, it seems to do it when pulling up at roundabouts and trying speed up especially when turning? The lad that looked at it said it could be the drive shaft ? But also said fuel filter. He also had it connected up for error codes and it didn’t show anything even with engine idling. 

 

Does anyone know if there is difference between drive shafts for the manual and semi autos?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.