Recommended Posts

Ford fiesta MK7 

2011 

1.4 diesel

Here goes...

I'm hoping someone on here can shed some light because my car has spent more time with a mechanic then with me this year 

My car started acting weird at the start of the year cutting out when idle turning off and things like that 

Then I went out the next morning and my battery was dead so it was changed that was Feb then we get to April same thing go out car is completely dead wouldnt start with a jump nothing so again the battery had to be changed just to get it to a garage and looked at turned out it was the alternator apparently thermostat was changed also so 2 batteries so far 

Get to July my car completely fails I had to rev the crap out of it to move then it turned off completely the fan was going so loud the clutch felt like it had no power but when I was in neutral my rev counter was going up and down with the air con on 

The car then went back to the garage alternator was checked and was in the red and it had gone into smart charge he took it out of smart charge and changed the battery again checked the alternator and all was fine get to today it's started doing it again except instead of the fan noise and the car feeling like it has no power and having to over rev to move it's making a noise that I can only describe as what it would sound like if you have a flat tyre or something has snapped 

 

Any help as to what any of that could be would be appreciated because the car has gone into smart charge 3 times has been in the garage about 4 times this year clutch has been checked things replaced 

Share this post


Link to post
Share on other sites

I'd consider taking it to another garage if I were you - perhaps even a specialist auto electrical place to diagnose what is going on - your existing garage are clearly fixing the wrong problem

Share this post


Link to post
Share on other sites
9 minutes ago, Westville said:

I'd consider taking it to another garage if I were you - perhaps even a specialist auto electrical place to diagnose what is going on - your existing garage are clearly fixing the wrong problem

Since the alternator and some other bits were changed It's been to 2 different people and each time they seem to just take it out of smart charge it works for a couple days then it goes back to doing the same thing 

 

Also forgot to mention it's just passed it's MOT as well no advisories but this problem wasn't happening when it went in

Would you recommend an actual ford garage ? 

Share this post


Link to post
Share on other sites

Have you tried an auto electrician?

There must be some good uns in your area -sounds to me like you need to find what is causing the alternator to behave like that

I have little faith in main stealers who use technicians and computer programmes instead of hard earned experience to diagnose problems which leads to a "replace it and see what happens" approach that can be very expensive for owners and never really addresses the problems.

A decent auto elec will give you an honest opinon before spending your money

Share this post


Link to post
Share on other sites

I agree with Westville.

but I don't understand what this means  "take it out of smart charge "

And I don't understand what this is " it's making a noise that I can only describe as what it would sound like if you have a flat tyre or something has snapped  ".

particularly "something has snapped ".  maybe alternator drive belt come off? or the alternator drive belt tensioner has broken (if it has a tensioner- I think that model does but not sure)

Share this post


Link to post
Share on other sites

I reckon you've got a battery drain somewhere...  Do you have anything permanently powered like a dash cam?  Or an aftermarket stereo?

 

Share this post


Link to post
Share on other sites
16 minutes ago, isetta said:

I agree with Westville.

but I don't understand what this means  "take it out of smart charge "

And I don't understand what this is " it's making a noise that I can only describe as what it would sound like if you have a flat tyre or something has snapped  ".

particularly "something has snapped ".  maybe alternator drive belt come off? or the alternator drive belt tensioner has broken (if it has a tensioner- I think that model does but not sure)

I have no idea what it means either everytime Ive asked he just says a power issue 

I described it as that because that's what I originally thought the noise was so I've pulled over checked and all my tyres are fine so the only other thing I can think to describe the noise is that something has snapped because that what it sounds like to me.

I'll mention everything you have said because I've got someone coming to look at it this week 

Thank you 

1 hour ago, Westville said:

Have you tried an auto electrician?

There must be some good uns in your area -sounds to me like you need to find what is causing the alternator to behave like that

I have little faith in main stealers who use technicians and computer programmes instead of hard earned experience to diagnose problems which leads to a "replace it and see what happens" approach that can be very expensive for owners and never really addresses the problems.

A decent auto elec will give you an honest opinon before spending your money

I've just booked an auto electrician to come out this week 

This is my first car so I have no idea what I'm to look for or what it could even be and no one to really ask the garages I've took it to just always seem to suggest more and more stuff do it but then it doesn't solve the issue that's why I've not took it back and thought id try my luck on here 

So thanks hopefully and auto electrician can sort it because this car is costing me a fortune already 🤣😭

11 minutes ago, TomsFocus said:

I reckon you've got a battery drain somewhere...  Do you have anything permanently powered like a dash cam?  Or an aftermarket stereo?

 

Stereo is the original one 

Dash cam was hard wired in

It all got removed when my alternator was done 😣

 

So nothing is in the car that shouldn't be at the minute 

Share this post


Link to post
Share on other sites
Quote

I've just booked an auto electrician to come out this week 

This is my first car so I have no idea what I'm to look for or what it could even be and no one to really ask the garages I've took it to just always seem to suggest more and more stuff do it but then it doesn't solve the issue that's why I've not took it back and thought id try my luck on here 

So thanks hopefully and auto electrician can sort it because this car is costing me a fortune already 🤣😭

Good on yer!! You are learning like we all do the hard (expensive) way - as I said before you need experience and expertise and not just a tecchie looking at a computer printout - hopefully now you will get sorted -ask him/her for an opinion before you commit to work being done. Keep us posted be interesting to see what the REAL problem is - good luck :wallbash:

Share this post


Link to post
Share on other sites
52 minutes ago, Westville said:

Good on yer!! You are learning like we all do the hard (expensive) way - as I said before you need experience and expertise and not just a tecchie looking at a computer printout - hopefully now you will get sorted -ask him/her for an opinion before you commit to work being done. Keep us posted be interesting to see what the REAL problem is - good luck :wallbash:

Thanks so much 

I will do 😬😬

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.