Sign in to follow this  
Wuly1554

Head light ssues

Recommended Posts

Hi just used my wife's fusion and noticed I was getting the noise you get when you need to replace indicator bulbs .

Checked bulbs by swapping with working ones for the other side and got nothing.

The strange thing is I have no main or dipped beam no indicator and when I switch main or dipped beam on my side repeater comes on permanently without using indicator switch.

 

Share this post


Link to post
Share on other sites

if this was mine I would be suspecting a faulty earth. To test that I would connect a spare piece of wire from the negative (earth) terminal of headlamp bulb holder to an earth point where there is some bare metal (probably more easily found on engine eg. alternator casing - you might need to clean surface to get good connection). that would test if that is the fault and then do something better as the fix.

(for anyone reading this who is not familiar with car electrics, the Earth on a car is not like the earth on your home mains power. The Earth on a car is effectively the negative power supply terminal)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this