Sign in to follow this  
Leigh12

Retro Fit Sat Nav to Fiesta MK7.5 Voice Guidance Help

Recommended Posts

The parts arrived and have fitted them but have some issues - can anyone help?

1) The map position shows my current location fine, but when I set a destination it maps it from the position the unit was last installed 100 miles away. I am guessing this will right itself when I take it for a drive?
 

2) No voice guidance is working so I can't hear directions being read which I want to hear. I am still struggling with this - I presume although I have not taken it for a test drive that when you start guidance it says something. I understand that two wires needed adding or re-routing:

”Fit the Sat Nav screen, two wires need to be connected from the Sat Nav unit to the radio, this enables the voice guidance.
Screen Pin 6 > Radio pin 4
Screen Pin 12 > Radio pin 5

Problem is I can see the numbers of pins looking into the ends of each connector, but don't know how to take them apart. Especially the one which is curved that goes into the screen. Maybe they don't and new ones that can be re-soldered or connected to are what I need to buy?

 

3) I have yet to run Forscan to change km to miles, ordered the socket to do this from laptop but not arrived yet,

4) Dab aerial - does anyone know what the original one that is factory fitted looked like - I found the below on easy but unsure what cable is need to get it to the stereo and how it is fitted in the bumper.
Ford Fiesta MK7 2011 - 2017 DAB Aerial Signal Booster - BA6T-18C847-AB  

Any help would be greatly appreciated 🙂 
 

Share this post


Link to post
Share on other sites

I never managed to suss out the voice, so I just left it without. 

I have 2 cars now, both with sat nav and the first thing I do is disable the voice. 

Share this post


Link to post
Share on other sites

Ok, update:

1) the position is all sorted now having driven around.

2) I have ran 2 wires joining existing at screen to empty positions 4 and 5 on radio - i get some voice guidance but it is hard to hear over some crackly interference that is constant during the speech - any ideas on what is wrong?
3) Still waiting kit to run Forcsan 

4) With on DAB arial connected - the menu omits dab so fine with that as don't need it.

So just the voice guidance issue - nearly there - can anyone help please? Thanks.

 

Share this post


Link to post
Share on other sites

All SORTED - I checked and I had got wire 5 not 6 on the screen. Simply reconnected to 6 and it works perfectly. If its helps anyone - I just left the exiting 2 wires in at the screen and cut them to join in my 2 new ones - then ran each down to the empty 4 and 5 pins on the radio = big plug of the two.

Share this post


Link to post
Share on other sites

Finally on running for scan I activated DAB and it works perfect with just usual arial - must be geared up already 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this