Cyber_killer

2009 1.6 TDCI Battery Light Staying on :(

Recommended Posts

Hi All,

I am hoping someone can help me with a 2009 Fiesta 1.6 TDCI Econetic. Nightmare car, bought it with bad ALT belt, replaced that also needed cambelt and injector seals! Anyway it has all been done but has been stood and moved around occasionally for 12 weeks.

Now the battery light stays on! I don’t think been stood and moved around has done it any good. The light wasn’t coming on until recently, so it is a fault which has happened in the couple of weeks

I have the following error codes:

P065B - Generator Control Circuit Range/Performance

P1632 - Smart Alternator Faults Sensor / Circuit 

 

battery at idle has a charge voltage of:14.68v

 

Anyone idea of tests etc I can carry out to determine the fault? I have given the battery a full charge off of a smart charger but it still has the same issue. It is the original Ford battery.

Before starting to replace things is there fuses or simple checks I can carry out with the multimeter? For diagnostics I have FORscan  & a universal Delphi.

Any help much appreciated and I am willing to learn 🙂

I do have couple more Fiesta’s in so can swap parts between if need be ( Rather not though)

Thanks,

Share this post


Link to post
Share on other sites

Are the wires on the alternator properly. The small wires I mean, are any broken from heat making brittle etc

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.