Sign in to follow this  
Oakley

MK7 Ford Fiesta Oxygen Sensor 1.0 Ecoboost

Recommended Posts

Hi,

I have a 2015 MK7 Ford Fiesta Red Edition 1.0 ecoboost 140bhp. The car has just hit the 50k mark and the engine managment light has come on. I tested it with an OBD2 reader and it turns out it was the Oxygen (lamda) Sensor Bank 1 Sensor 1 (pre cat). I managed to get my hands on one and had it replaced and cleared the code using OB2 reader. i drove about two miles and turned the car off and back on and to my suprise the engine managment light came back on, I then reset my ECU by dissconnecting the battery from the car and left it for 10 mins before reconnecting it however the light is still on.

I have read something about drive cycles and how the car needs to go through a certian number of drive cycles before the monitoring system resets and could even be up to 100 Miles. Does anyone know anything about this or anything els i could try or if this drive cycle thing is even a thing?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this