Happychappie

Cooling fan on all the time

Recommended Posts

Hi, I have a 1992 cabriolet XR3I 1.8EFi 105BHP.

The fan is on all the time and the temp gauge is not rising at all. Does any of you guys know what the problem might be.....would be a great help....cheers

Share this post


Link to post
Share on other sites

Sounds like either wiring or fan fault or faulty fan temp sender.Pull off wiring plug from sender if fan stops and water temp is normal then most likely faulty sender.

Share this post


Link to post
Share on other sites
20 hours ago, Comares2001 said:

Sounds like either wiring or fan fault or faulty fan temp sender.Pull off wiring plug from sender if fan stops and water temp is normal then most likely faulty sender.

yes agree with Brian.

Share this post


Link to post
Share on other sites

I offer no insight into your fault, just wanted to say how envious I am of your car, I test drove one in the 90s but ended up getting an RS Turbo instead, still that test drive still sticks into my head. That is one sweet ride... 😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.