Jump to content
Do Not Sell My Personal Information


St180 engine hesitation/stuttering


Recommended Posts

Hi Guys I'm having a problem with my st180. I've had the car since July it's on 30k miles, clean history and 1 previous owner. 

I replaced the Maf sensor yesterday as it had about 80% power loss and had a "service engine now" message accompanied by the spanner light on the dash. It threw up a MAF sensor fault code, so I had it cleared and replaced the MAF with a new HAAS one. Drove it home after work and everything felt better than ever. 

On the drive home tonight I gave it a few pulls to make sure the car was still operating as it should and as it hit 4k rpm the car really struggled to get past that and started to violently stutter and kangaroo. I tried this a few times to make sure and it's a definate issue. Under 4k rpm it operates as it should and there is no warning light this time. The only modification to the engine is an ITG induction kit that I've had on since September with no issues. 

I haven't checked for boost leaks or anything of the sort yet as I finished late from work. I quickly checked the secret dash menu for fault codes and it said "none". 

Anyone have any suggestions or ideas for what this could be and how I should tackle this? 

Thank you. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership