Jump to content
Do Not Sell My Personal Information


heated front and rear switch not working


Recommended Posts

Can anyone help with my problem please, the switch that turns my Ford Fiesta front and rear heated screens stopped working, I checked the fuses under the bonnet all ok, then a few days later they started working again but the lights on the front and rear switch have stopped working again any ideas ?

Link to post
Share on other sites

Bummer mate! I am don't know much about electrics, but do you here a click when you press the button for either of them? I think the click comes from the relay. If you changed the fuses but still don't work and you don't here a click when you turn them on, might be the relay.

Link to post
Share on other sites
9 hours ago, titanium greg said:

Can anyone help with my problem please, the switch that turns my Ford Fiesta front and rear heated screens stopped working, I checked the fuses under the bonnet all ok, then a few days later they started working again but the lights on the front and rear switch have stopped working again any ideas ?

have you removed the panel, it sounds like a loose connection

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership