Jump to content
Do Not Sell My Personal Information


Brake shoe replacement


Recommended Posts

Hi all, I replaced the rear brake shoes in my 2010 focus mk2.5 saloon and it was all good, but I now have no handbrake! It’s gone very loose and just doesn’t work at all. I don’t know what I did wrong because I put the shoes on the very same way they came off and did all the adjustments. Any idea what I can do? Thanks

Link to post
Share on other sites

Pump the Brake Pedal for a long time because it takes the Self Adjusters ages to bring the shoes back to where they should be sitting. That is assuming that you did connect everything up correctly.

Link to post
Share on other sites

Did you definitely attach the cable to the levers on the rear-most shoes ??

Assuming you did, then did you adjust the shoes up manually before re-fitting the drums ??

Link to post
Share on other sites

Make sure the adjusters are the correct way around and greased and use something to move the adjuster manually to move the shoes as far out as possible but just enough to fit the drum over them. Driving in reverse then pumping the brakes normally helps but manually moving the adjuster will tighten up the hand brake problem. You will hear a slind grind at first but it wears off. I also found this video to be very helpful when I had my mk2 with drum brakes even though its for an escape 😂 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership