Jump to content
Do Not Sell My Personal Information


mk6 p0404 after cleaning egr valve


Recommended Posts

Hi folks i got a mk6 ford fiesta 08 plate and recently i have cleaned the egr valve, had some hickups along the way and had to change the egr cooler since the side that goes with the egr valve was bent and was leaking gases(heard hissing sounds coming from the egr valve/cooler P0404 code) that being said i came back home, the next day i start my car and the check engine light comes on. get my obd2 scanner got P0404 code.

Today i have went and got the top off from the egr and wanted to check if I've managed to put everything back as it should which from my side looked ok but to make it clear I am no car mechanic nor experienced with cars, this is my second car ever and trying to do as much work by myself to learn more about how cars work and how to fix things.

I got back home today hoping the check engine light goes away but when i turned the engine off, and on again the check engine light came on, I have no clue now what to do and dont want to pay for a mechanic so would very much appreciate all the help I get.

I haven't checked the error code this time but i bet its still p0404, will update when i get a chance to go out and check the error code.

Sorry if i have missed something out, am new to forums in general and this forum in particular. so please just ask.

Thanks for your time, Sebastian

Link to post
Share on other sites

Thanks for your reply, Its weird as before trying to clean the valve i haven't had the check engine light turned on, I just done it as it seemed real sluggish and people on different forums said that egr and maf sensor kill performace(not saying that my 1.4tdci is a performance car) and i doubt that the electrical side would get damaged within 2 weeks of trying to sort the egr cooler. I got the cooler and valve together for 35 pound of ebay(the egr valve was more clogged up than mine that came with the car) so i got another valve lying around so might try swapping the electrical sides and see if that works but in the mean time I would like to get as much info on how to tackle this problem as it takes a bit of time to get to the valve

Link to post
Share on other sites
13 hours ago, 5384exe said:

Thanks for your reply, Its weird as before trying to clean the valve i haven't had the check engine light turned on, I just done it as it seemed real sluggish and people on different forums said that egr and maf sensor kill performace(not saying that my 1.4tdci is a performance car) and i doubt that the electrical side would get damaged within 2 weeks of trying to sort the egr cooler. I got the cooler and valve together for 35 pound of ebay(the egr valve was more clogged up than mine that came with the car) so i got another valve lying around so might try swapping the electrical sides and see if that works but in the mean time I would like to get as much info on how to tackle this problem as it takes a bit of time to get to the valve

Did you reset the EGR adaptions after taking it apart?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership