Jump to content
Do Not Sell My Personal Information


Help PLEASE!!! 2006 2.4 TDCI Transit


Recommended Posts

Hey all, bought a ford transit recently 2006 2.4 TDCI. Van starts up fine first time but if revs go over 1500 it shuts down immediately. It will start back straight away but again at 1500 rpm shuts down again. I can leave it running without revving and no issues.

 

Initially diagnosed as the Diesel Fuel Filter housing might be letting air in when revving. Had fuel filter and housing replaced today....same issues 😪😪.

 

When ignition goes on theres only oil pressure light on which goes away when turned on. When it shuts down the glow plugs(I THINK...looks like coil springs) and oil pressure light comes on. 

 

ANY help would be great. Driving myself insane!

Link to post
Share on other sites
14 hours ago, Skundle said:

When ignition goes on theres only oil pressure light on which goes away when turned on. When it shuts down the glow plugs(I THINK...looks like coil springs) and oil pressure light comes on. 

So no check engine light with ignition on before starting?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership