Jump to content
Do Not Sell My Personal Information


P056 code


steplce74
 Share

Recommended Posts

Had a lamba sensor fitted, sensor 2, bank 2,  the engine light sometimes come back on with the same code P0156, now I am getting a code P056 from sensor 2, bank 2, I have no end of electric issues in the 4 years I have owned my car, any ideas, thanks

Link to comment
Share on other sites


2 hours ago, steplce74 said:

I have no end of electric issues in the 4 years I have owned my car, any ideas, thanks

 

11 minutes ago, steplce74 said:

the cat was fitted 4 years ago

 

I don't think that's a coincidence lol.  Seriously though, it can take months or even years before faults show up.  Same happens with DPF deletes and EGR removal on some engines.  They work fine for a while, but then the ECU seems to suddenly realise somethings wrong and start throwing faults months or years down the line.

Link to comment
Share on other sites


19 minutes ago, unofix said:

I'm a bit puzzled by the fact you say it is Bank 2 on a straight 4 cylinder engine. 🤔

 

Same as the previous thread. His vehicle should have 2 cats in parallel therefore bank1 sensor 1 and sensor 2 is one side and bank2 sensor 1 and 2 the other side. 

Link to comment
Share on other sites

been quoted £500 for a new cat plus the cost of 2 more lamba sensors so about £700, no guantee of stopping the engine light going out due to all the electric problems i have had so far, 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership