Sign in to follow this  
DESPERATE_STU

Starting Delay On 54 Diesel Galaxy

Recommended Posts

Help please as new to this site. Just got a cracking 54 plate galaxy but had an irritating starting issue. Once glow plugs out, i turn the key and fires, then as though power all gone and if hold key for a couple of seconds starts no probs. Thought due to time of year battery so got new one but no difference. Any ideas? Worried the wife and kids will get caught out one morning !

Share this post


Link to post
Share on other sites

Could be a glow plug issue then.

Best bet would be to get it plugged into VAG com diagnostic software to read the fault codes.

VAGCOM?? For a Ford??

Don't you mean IDS?

Share this post


Link to post
Share on other sites

I didn't know that...

I'm guessing it's the same engine as in the VW sharan and the Seat Alhambra (or whatever it's called) as its the same shape then...

Share this post


Link to post
Share on other sites

yep they were all made(iirc)in portugal.

the ford galaxy tdi is about 95% vw.obviously the badges,clock(mk 2)and wiring are specific.

thats why fords no sod all about them.and also charge an arm and leg for parts they dont make,but buy from vw.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this