Jump to content
Do Not Sell My Personal Information


2001 Fiesta Mk5 1.3 - Idle Control Valve Issue?


thm93
 Share

Recommended Posts

Hi People,

I'm having a problem with my Mk5 Fez, and was wondering if I could get any advice from you FOCers! ;)

I have the "wonderful" 1.3 Endura-E engine first and foremost, which means the wonderful 8v of tappets! Anyway, the car is holding a constant high (approx 2000 - 2500) rpm on idle, and increasing further every time I push the clutch down.

I'm pretty sure it's an idle control valve issue, as I've seen from my research that this is a pretty common problem. I DC'd the valve along with the black plastic bracket behind, gave them both a spray and wipe over with WD40; but to no avail.

I've got a pretty strong feeling that it's to do with some kind of loose connection. I've had this problem before well over a year ago, the last time I changed the oil (I know, I should do it more often!). More to the point, it was the last time I took the oil cap off (the one with the two breather pipes, in yellow on the link). I don't know how that could have affected the idle control valve, but it's too much of a coincidence that the last time this happened was the last time I pulled that cap off.

http://www.askthemechanic.co.uk/images/Ford%20KA%20idle%20control%20valve.jpg

Thanks in advance for any help!

Tom. :)

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership