Jump to content
Do Not Sell My Personal Information


Starting problem on my ford galaxy


philip1976
 Share

Recommended Posts

Hi everyone like the title says i have a problem on my galaxy,i had called out the AA and he said its a problem with the fuel pump, so i bought a new fuel pump but its still not starting was told then it could be the relay so i have changed this but still my galaxy wont start!!this is driving me mad now :( any ideas what it could be?thanks

Link to comment
Share on other sites


Hiya mate,

have you checked to see if your fuel pump cut out switch needs resetting?

steve

www.sr-performance.co.uk

I have given up and took it to a garage today they have had it all day and havent found the problem yet,they said a auto electrician needs to look at it,arrghhh it driving me mad

Link to comment
Share on other sites

never heard owt good come from AA man's mouth before, had a toe to toe argument with an AA man on a main roundabout when cambelt snapped on my lads 1.2 punto, i got to him to find his belt snapped and prat from AA said his engine was knackered due to valves hitting head.

well, after calling him every ueseless git i could think off i made him tow car to mates garage who promptly changed belt in 30 mins.. just like i told AA man who left a bit embarased. hope you get itsorted soon mate.

steve

www.sr-performance.co.uk

Link to comment
Share on other sites

FINALLY GOT IT SORTED ;) the auto electrician guy had a look at it this morning and said its something to do with the immobiliser,the garage rang me up and asked if i have another set of keys which i have then went down to the garage with the other set of keys,turned it over and it started straight away!!! cant believe it was all down to the key,AA man made me waste money on a new fuel pump :angry:

Im delighted its back to normal now went through alot of trouble,PHEW

Link to comment
Share on other sites

  • 10 years later...

Hi folks I've had the same issue with my galaxy on a 2014 model and it took me few days to figure it out and it turned out to be the fuel filter housing which had a hairline crack make sure you purchase a new one from the dealer ship and it will not have issues with it again 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership