Jump to content
Do Not Sell My Personal Information


Non Starter


Recommended Posts

Hi there, first off I'm sorry if this is in the wrong place but im typing from my Samsung s4. Basically this is my last attempt before I send my ecu to be tested/repaired. So I own a mondeo mk2 1998 2.0 16v ghia with a zetec engine. So I broke down the other day when without any warning the engine cuts out. No lights on dash it was as if you just switched the ignition off. The Rac came out and put it on the computer and came up with no codes. So he went about testing varies parts which is the common problems. We've tried the crankshaft sensor and that's working fine and within tolerance of its recommended resistance. Fuel rail has power. Coil pack is fine but no spark we know this because he tried a new one. Immobiliser is fine the light by the clock goes out. Rac have said he thinks the ecu isn't switching the coil when you crank it. Coil has power coming up to it when ignition is on but as soon as you turn the key to crank nothing. If anyone has any ideas before i send the ecu away would be great. Thanks in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership