Sign in to follow this  
micky21

Warning Light

Recommended Posts

got the engine warning light just come up on my 2009 titanium and it feels juddery when I'm driving any ideas of the problem before I take to the garage please

Share this post


Link to post
Share on other sites

Could be plugs/leads/coil related, define 'juddery' ....... Is it 'holding back? (Btw hi fellow west Lothian ford owner)

Share this post


Link to post
Share on other sites

feels like its misfiring when I accelerate and when it ticks over it stutters, stutters when driving aswell

Share this post


Link to post
Share on other sites

Could be coil pack on its way out along with plugs and leads, check the leads resistance with a multimeter , if you don't get any reading using a meter then they're shot. ( I had a barely noticeable misfire on my fiesta that bugged me for over a year, turned out one lead had packed in! )

Share this post


Link to post
Share on other sites

Did you get the issue sorted? If not, could be worth checking your Oxygen Fuel Sensors. On mine (Fiesta) I have two, one on the exhaust manifold, another on the pipe itself. Engine management lights are for wide variety of things - mine came on, and it happened to be the oxygen sensor, I had similar symptoms too. Good luck!

Share this post


Link to post
Share on other sites

is all sorted was a misfire on 4th cylinder plugs and leads shot fixed and running sweet cost £45 so not a bad fix was expecting a lot more

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this