Sign in to follow this  
Ken Emery

Ken Emery

Recommended Posts

Hi

I have had 12 Galaxy's, in 12 years they have been working cars for private hire (taxi) work.

I had a 2011 Galaxy 2.0lt, the oil pump failed at 80, 000 miles, I had it replaced.  The second one failed at 75,000m, I had that replaced, and traded that car in.                                  I already had a 2012 Galaxy Titanium X 2.0lt, at 85857 miles, the pump failed, unfortunately it was the same driver in all 3 cases.  He has worked with me for 8 years, so I know he is a very steady driver.  Oil changes have been made as required, not always on the dot, but around the mileage listed.  Anything my cars have required, they have, they have to be reliable, I feel that these types of Galaxy's are now NOT reliable.  BE AWARE

I got in touch with Ford UKCS, and it was like a brickwall, I got no where, they wouldn't even put me through to someone who knew about the previous oil pump failures. It was the standard statement that came out "there is no problem with Ford oil pumps in these engines"   The latest one to fail came as Ford mysteriously ran out of oil pumps in stock, back ordered, if there is no problem, why aren't there stocks on the shelves at FMC Parts.

Can anyone out there offer any suggestions, I have seen a Motorhome forum which had problems with pumps, for the Ford, Peugot engines, evidently they are the same.             Does anyone have any knowledge about these oil pumps please, my newer Galaxy is approaching 75000, and I have a 65 plate Galaxy , will this also fail at 75-85000 miles. ? Earlier in my Galaxy ownership I bought a 2007 plated model, it did 225,000, same clutch, same oil pump, it was a lovely ride, but eventually t had to go.  My cars are high mileage, but cared for very well.

The mechanic who has serviced all the cars I trust, Ford Motor Company, I do not.   I am down nearly £2000.00 on the three oil pumps, plus the lost business, and Ford is burying its heads in the sand and denying there is a problem, these engines are not just in Galaxy, they are in Mondeo, SMax etc.  BE AWARE

I would be really grateful for any help, suggestions that anyone has, if its even get rid of the Galaxy's.

Thank you.  Ken

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this