Sign in to follow this  
Pembo

DEAD BATTERY :(

Recommended Posts

hello guys,

 

New to the site so hope this post is in the right place.

 

So I have a 2006 Galaxy which has had a few dramas over the winter, the usual DEAD battery. So after endless recharging, I replaced the battery. Low and behold the battery died again. The first time I did check the alternator which seemed fine, but this time the alternator wasn't supplying enough charge, so I replaced it.

 

A couple of days later battery died again WTF! 

 

So I can only assume there is a drain on the battery now as everything else is new and working fine. I have tested all the fuses and nothing seems to be enough draw to kill a battery overnight. So after banging my head and sat in the car crying.suddenly I heard a switch from the fuse box this is some 30 to 40 mins after the engine has stopped running, It seems one of the relays is switching with no ignition on! 

 

So could the relays be switching the glow plugs on? could this be the drain on my battery

 

I've heard this switch many times now even hours after the car has not moved. This is passed my home mechanic skills so any help would be appreciated. I've attached a picture of R2 I can feel the relay switching. Please help!

Galaxy.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this