Sign in to follow this  
pacman1500

Electric window fault

Recommended Posts

I have a problem with my drivers side electric window.  The window will go down but won't go up.  There is no noise or movement at all when i press the up button.  The passenger window is working fine.  If anyone has any solutions i'd appreciate the help.  

Share this post


Link to post
Share on other sites

It doesn't harm to try the simple stuff first; try to 'reset' your window button, see this topic:

If that doesn't do it then flip out the button by sticking a flat plastic (or screwdriver) under it and check the wires and reconnect it; try if this has fixed anything.

I'm afraid you'll come to the last option though..🙄 Your window regulator might be broken; You can replace it yourself easily; just take of the door card and bolt in a new one (make sure you get one with the little motor). There are probably even video's on youtube about this.

Hope this helps.

Share this post


Link to post
Share on other sites

it could be a faulty switch. If you get the connector off the switch you could use a bit of wire to bridge the two terminals that the switch would put together if working. I can't tell you which two wires though, it would possibly need a wiring diagram consulting. But it might be obvious from the layout of the terminals on the bottom of the switch.

Share this post


Link to post
Share on other sites

if it does turn out to be the switch and need to fix now and not wait for new one, maybe change connectors over so you can use the passenger window switch on the drivers door for the drivers window.

Share this post


Link to post
Share on other sites

Thanks for the responses.  You were all 100% accurate, it was the switches.  Typical of me, the most obvious solution is always the last one i check lol

Share this post


Link to post
Share on other sites

I have the same problem with my car. I have a 04 fiesta zetec 1.4 I  opened the window it made a a crunching noise.and when I closed it wouldn’t go all the way up then the eac fail came up on my dashboard. Does anybody know what the problem is 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this