Sign in to follow this  
ILR1975

Ford Focus Zetec 61 plate rear electric window

Recommended Posts

Hi all,

Looking to fix passengers rear electric window as its not working, the switch does not operate from either the drivers controls or the rear switch, there is also no illumination on the rear switch. faulty switch or broken/loose wire maybe?. any info would be much appreciated. its a 61 plate Zetec 1.6 TI 

Thanks  

Edited by ILR1975
Title Infomation

Share this post


Link to post
Share on other sites

check the wiring in the convoluted rubber imbetween the door and the body. does the affected door lock/unlock ok? 

Share this post


Link to post
Share on other sites

Just noticed the door does not lock either and no power at window switch. The door stays unlocked all the time

Share this post


Link to post
Share on other sites

You will need to check for broken wires then first, or corrosion at the connectors at the end on the convoluted rubber 

Share this post


Link to post
Share on other sites
On 6/23/2018 at 6:45 PM, iantt said:

check the wiring in the convoluted rubber imbetween the door and the body. does the affected door lock/unlock ok? 

When this very fault occurred on my car, the fuse for the door module had gone.

Fixed it months ago and the window & lock has worked perfectly ever since.

Fuse 118 for the left rear door on my car, check the fuse number for your model.

These fuses are in the passengers foot well.

ScaniaPBman.

Share this post


Link to post
Share on other sites

1 hour ago, ScaniaPBman said:

When this very fault occurred on my car, the fuse for the door module had gone.

Fixed it months ago and the window & lock has worked perfectly ever since.

Fuse 118 for the left rear door on my car, check the fuse number for your model.

These fuses are in the passengers foot well.

ScaniaPBman.

good call on the fuses to check, think the car he has is mk3, so fuses for this are in the boot area im led to believe. fuse 6, 25 amp

Share this post


Link to post
Share on other sites

Got in car to make a short journey and the window worked, stopped at petrol station and it no longer works!! door lock not checked while window was working though.

Share this post


Link to post
Share on other sites

Evening all, checked fuses and all four 25 amp fuses are okay, these are in the boot on the left hand side. wiring in door has still to be checked. returning to dealer as only had the car for 7 weeks, 12 month warranty included.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this