Jump to content
Do Not Sell My Personal Information


Ford Sync 2 Problems


 Share

Recommended Posts

Hi, first time on this forum although I've always had fords. Recently I went from a 2015 focus zetec s to a 2016 focus st2. Both cards have had sync2 with navigation packs but recently, maybe in the past week or so, the st has had nothing but bother with it and it's now got to the point that I can't actually use it.

When I try to select 'home' on navigation or any destination for that matter it doesn't show anything at all and reverts back to the map. Also when I use the phone on it I can't select recently called  instead it takes me to my phonebook. 

Tonight I tried to reset the system but with no joy as all the menu on settings came up with 'enable valet mode.

Also, a few weeks ago me and my partner went on a road trip for a weekend away and the navigation card wasn't being accepted by the vehicle (the card that came with the vehicle) and along with that nightmare none of the usb ports or the 12v sockets would work. 

Has anyone had any similar problems?

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership