sailor-caz

Ford Fiesta ecoboost 1.0 2012

Recommended Posts

Hello

All of a sudden my heater / blower has stopped working properly - it now only works on no. 4? It's 4 or nothing!

Can anyone advise on what the problem might be and whether it's an easy job to carry out?

many thanks

Share this post


Link to post
Share on other sites
 

 Heater Resistor  I don't no where they are on a fiesta but I don't think there that hard to do google it

Share this post


Link to post
Share on other sites

Thanks. Where is the best place to get the part?

Share this post


Link to post
Share on other sites

main dealer or ebay depends what you want to pay for it and what you trust

Share this post


Link to post
Share on other sites

58 minutes ago, sailor-caz said:

Thanks. Where is the best place to get the part?

Do you want us to fit it for you too? 😁

Only joking, I replaced a friend's and bought it from a Ford main dealer.

Here you go

https://www.fordpartsuk.com/heater-fan-resistor

Share this post


Link to post
Share on other sites
48 minutes ago, WES180 said:

Do you want us to fit it for you too? 😁

Only joking, I replaced a friend's and bought it from a Ford main dealer.

Here you go

lmfao :smile:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now