Recommended Posts

Hi,Got 2009 1600 TDCI that last power and rough idle. Code showed EGR stuck open

I cleaned it and was fine for a couple of weeks then the rough idle returned so I fitted a new EGR. Was told that reprogramming was not required and nothing on dash.

Its not performing how it should IE sluggish pulling away and slows down on long inclines etc.

Any advice would be appreciated.

Thanks

Share this post


Link to post
Share on other sites

Im no expert here as ive only had my focus 1.6tdci a month (and ive had my own problems!) but I have read a few times about sluggish performance and uphill struggles, possible fuel filter issue.

Share this post


Link to post
Share on other sites
23 hours ago, garymoore said:

Hi,Got 2009 1600 TDCI that last power and rough idle. Code showed EGR stuck open

I cleaned it and was fine for a couple of weeks then the rough idle returned so I fitted a new EGR. Was told that reprogramming was not required and nothing on dash.

Its not performing how it should IE sluggish pulling away and slows down on long inclines etc.

Any advice would be appreciated.

Thanks

The new EGR does need to be reprogrammed and this can be done with Forscan. I think a car with a new EGR that hasn't been reset will run but won't be smooth.  So I would definitely start with that and then look at other things if that doesn't change anything.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.