Recommended Posts

looking at getting a 16 plate fiesta 1.0 ecoboost   not taken it for a test drive yet hopefully will have it sorted in acouple of months, any pitfulls to look out for. t.i.a.

Share this post


Link to post
Share on other sites

check for rust on the water colling pipes that go into the turbo. hopefully it won't be an issue on a 2016 car but some have had rust seeting in when not very old.

This is a long thread with 427 replies from many people with photos of rust on their pipes

 

Share this post


Link to post
Share on other sites
1 hour ago, isetta said:

check for rust on the water colling pipes that go into the turbo. hopefully it won't be an issue on a 2016 car but some have had rust seeting in when not very old.

This is a long thread with 427 replies from many people with photos of rust on their pipes

 

I thought this was limited to 2013/14 cars?

Share this post


Link to post
Share on other sites

I haven't had any issues with my 2014 100ps ecoboost. Just had to get used to a different driving style ie don't let the revs drop as at low revs it's a bit gut less. As above check the turbo cooling pipes and make sure it has the correct oil and has been changed frequently.

Share this post


Link to post
Share on other sites
2 hours ago, Cameron583 said:

I thought this was limited to 2013/14 cars?

It shouldn't affect a 2016 but worth checking anyway - since if it does affect it, it could eventually be an engine killer if left unpainted. 

Share this post


Link to post
Share on other sites

thankyou for getting back will have a good loking when I take it for a test drive

Share this post


Link to post
Share on other sites

"I thought this was limited to 2013/14 cars? "

I am not going to read through the 427 replies right now but when I have read the replies as they were added gradually, I am pretty sure there were examples of cars later then 2013/2014 which had rust on these pipes.

Anyway, it's easy to see when you open the bonnet without having to move stuff out of the way

Share this post


Link to post
Share on other sites
16 hours ago, Cragrat said:

I haven't had any issues with my 2014 100ps ecoboost. Just had to get used to a different driving style ie don't let the revs drop as at low revs it's a bit gut less. As above check the turbo cooling pipes and make sure it has the correct oil and has been changed frequently.

Highly worth remapping 🙂 A stage 1 gets you a very decent performance uplift, resulting in a really nice pull. The extra torque lets you pull away in 2nd gear quite easily now

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.