Adam_v64

Ford Bluetooth Problem

Recommended Posts

I have a 2010 Focus with a bluetooth module, and a Travelpilot FX head unit. I updated the BT module firmware to the Nov 2012 version (possibly the last release?) , but its crap for streaming audio. Lots of intermittent pops on it. Voice calling seems fine.

Im using an iPhone SE with the latest IOS.

Ive read of similar issues, is there any solution short of replacing the head unit and doing away with Ford's bluetooth module? Is it just too old work properly?

Its a real shame as in theory it should work great. I wouldn't mind too much but while the USB port plays audio from the phone just fine, it doesn't deliver anywhere near enough current  to charge it properly.

Share this post


Link to post
Share on other sites

 Has the bluetooth allways been like that or only since the upgrade, if its allways been like that then you need to upgrade the module to one that does music streaming, , re USB its not designed to charge, its very low output.

Share this post


Link to post
Share on other sites

I haven't had the car long, but it did it when I bought it, and I don't think the update made any improvement, except for making the USB connection play music through the phone.

I believe my car has the later versions of stereo and wiring as all the PNs I can see start "9M5T", rather than "8M5T"

I wonder if anyone else here uses a modern iPhone with their Ford bluetooth without problems? If they do perhaps mine is faulty - looking online they seem to have stickers stating "scrap if dropped", perhaps they're fragile little things..

 

 

Share this post


Link to post
Share on other sites

The module fitted is 8M5T - 19C112 - AP - "bluetooth voice connectivity with USB". I wonder is this the correct module?

Share this post


Link to post
Share on other sites
4 hours ago, Adam_v64 said:

The module fitted is 8M5T - 19C112 - AP - "bluetooth voice connectivity with USB". I wonder is this the correct module?

Im not well up on module numbers but to stream you need a later module they are easy to change. That module would have been correct at time of manufacture and specification of the car.

Share this post


Link to post
Share on other sites
8 hours ago, Adam_v64 said:

I have a 2010 Focus with a bluetooth module, and a Travelpilot FX head unit. I updated the BT module firmware to the Nov 2012 version (possibly the last release?) , but its crap for streaming audio. Lots of intermittent pops on it. Voice calling seems fine.

Im using an iPhone SE with the latest IOS.

Ive read of similar issues, is there any solution short of replacing the head unit and doing away with Ford's bluetooth module? Is it just too old work properly?

Its a real shame as in theory it should work great. I wouldn't mind too much but while the USB port plays audio from the phone just fine, it doesn't deliver anywhere near enough current  to charge it properly.

I've got a Ford Sony 6 disc sony DAB head unit CD345-MCA SONY DAB , a Chinese VAG loom and BVC 8M5T-119C AT module running Nov 2012 update.  Its sound quality is perfect, loud and crystal clear using bluetooth on either a Samsung j5 pro or an Apple 6s  I'm shocked how well it works.  The same head unit and https://www.ebay.co.uk/itm/Kinivo-BTC450-Bluetooth-Hands-Free-car-kit-for-cars-with-aux-input-BTC-450/173946466140?epid=16011369201&hash=item2880046f5c:g:80wAAOSwRJpdFNKm was a total disaster zone.  Almost no audio output and lots of interference even with a ground loop isolator.  Oddly that device was OK on the original CD6000 head unit

Share this post


Link to post
Share on other sites

I fear it will come down to some unique compatibility / firmware issue.

ive bought another TravelPilot head unit to try, thinking it was that.  I did have some pops and clicks on FM too - nothing like the bluetooth problems tho. But now I think about it I reckon it’s the bluetooth module, or the combination of that and head unit. So will probably end up re-eBaying the new head unit...but let’s see. I’ll confirm back what happens. The FM problems might be explained by poor reception and “sharx” processing on the FM front end. 

I suspect if I got another BT module of the same model I may well have the same problem. So I either look at others that might work better (or rather spend more money and hope), or say sod it and get an aftermarket unit fitted 😞

 

 

Share this post


Link to post
Share on other sites

Interesting.....Well, I have SP 4.1 installed to the travel pilot FX. I believe that is the last edition. My BT module is fine and totally supports streaming of audio.

The NX model of Travelpilot, which appears to be a later model, and saw more updates, has a V5.1 firmware that has an interesting fix in its release notes:

"fixes audio dropouts via bluetooth streaming of less than 1 sec"  - which sounds like my bluetooth problem

But this fix hasn't been implemented on the FX and at this stage is never going to be.

So ultimately, its looking like the travelpilot FX head unit is no good in todays world for bluetooth streaming from mobile phones. Thought I'd add this in case anyone else is struggling with it.

Im going to sell that and the BT module and get a new Sony unit fitted

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.