Mattjay94

Bond express interior LEDs

Recommended Posts

Hey guys,

 

my LEDs have finally arrived for the interior of my 2014 fiesta and after eagerly opening the package they are not what I was expecting! They just look like little LED chip sets and I’ve no idea how I would begin to install these. Any help would be appreciated, cheers  

C1AD1B57-CE58-410A-8427-3810A864A4AF.jpeg

Share this post


Link to post
Share on other sites

I had similar when I was replacing some footwell lights on an A4 but turned out the OEM ones were the same and they just plugged in despite looking very strange.

If you haven’t pulled the old ones yet, do that first before you worry about it too much.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
5 minutes ago, Daggerit said:

I had similar when I was replacing some footwell lights on an A4 but turned out the OEM ones were the same and they just plugged in despite looking very strange.

If you haven’t pulled the old ones yet, do that first before you worry about it too much. emoji4.png


Sent from my iPhone using Tapatalk

Cheers for the advice mate! From what I can tell though the footwell lights (where I’m presuming these new ones will go) is an actual bulb with a screw cap so there’s no way these would screw in 🤷‍♂️ 

Share this post


Link to post
Share on other sites

I had similar when I was replacing some footwell lights on an A4 but turned out the OEM ones were the same and they just plugged in despite looking very strange.

If you haven’t pulled the old ones yet, do that first before you worry about it too much.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
12 minutes ago, Daggerit said:

I had similar when I was replacing some footwell lights on an A4 but turned out the OEM ones were the same and they just plugged in despite looking very strange.

If you haven’t pulled the old ones yet, do that first before you worry about it too much. emoji4.png


Sent from my iPhone using Tapatalk

To be fair mate you were right, I pulled one of the bulbs out and the new one simply did just slot in! Thanks for you help man, appreciate it 

Share this post


Link to post
Share on other sites
On 8/24/2019 at 10:58 AM, Mattjay94 said:

To be fair mate you were right, I pulled one of the bulbs out and the new one simply did just slot in! Thanks for you help man, appreciate it 

No worries, I'm glad it was that easy for you!  :)

Strange looking bulbs though aren't they?

Share this post


Link to post
Share on other sites
On 8/26/2019 at 7:45 AM, Daggerit said:

No worries, I'm glad it was that easy for you!  🙂

Strange looking bulbs though aren't they?

They sure are, I thought I wound have needed some kind of connectors or something for them so I could believe it when I plugged the first one in and was blinded by a blue light 😂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.