Jimmyw

Whining noise

Recommended Posts

Hi, I seem to be having a issue with a whining noise coming from the area of the aux belt of a mk 6.5 fiesta tdci. I did notice some wear in the shaft of the power steering pump pulley, so I changed it for a second hand item.

Unfortunately it now has the same issue. I didn't detect any wear when buying it. I removed the belt and there is no sound then, so the problem is not with the timing belt, which was changed in the last 2 years. The power steering fluid was black, which I have flushed and changed.

Is the PS pump a known weak point,or is there another possibility? 

It would be nice if I could isolate the pump on a temporary basis to test.

Share this post


Link to post
Share on other sites

Finally found out the cause of this, I changed both the idler pulley and the tensioner of the aux belt and, voila!!, silence.I can now take out my ear plugs.It probably should have been done when the other stuff was done, i.e timing belt, alternator, and belt itself relacement.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.