Jacob2000

Mk7 fuel problem

Recommended Posts

Hi I have a fiesta mk7 1.25 (2010) and recently my fuel hasn’t been efficient, at the moment I have done 92 miles with half a tank, I do about 20 miles a day and there is no leaks from my car, anyone know what could possibly be the problem. Thanks 

Share this post


Link to post
Share on other sites

Is there any noticeable loss in performance along with this?

Share this post


Link to post
Share on other sites

Nothing, I had a custom exhaust back box changed, but if anything after that the car feels faster and haven’t noticed any performance loss

Share this post


Link to post
Share on other sites

Not wishing to start a fuel debate but which vendor are you using for fuel?

In my 125 Ecoboost I used to use Tesco, power started dipping as you mention, then engine management started coming on. Sought advice and was informed how to reset the light (steady on driveable, flashing do not drive). Switched to Shell V-Power and after several tanks performance was back to normal.

Investigated and was informed the most likely cause was carbon build up that the V-Power additives have cleared.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.