Bigkoll

Black smoke and bad performance

Recommended Posts

Hi all, drove my C-max 2007 to my sons house last Wednesday night. 

on the way i heard a pop and what seemed like a hiss of air and lack of power engine light came on 

(later found code to be p010f mass or volume airflow sensor)

i have noticed oil around the pipe behind rocker cover top left of engine (sorry for poor description)

any help appreciated, thanks in advance.

p.s. i will try to answer any questions but not very much knowledge with parts.

Share this post


Link to post
Share on other sites

Sounds like an intake pipe has come off or split which would've messed up the MAF readings.

Share this post


Link to post
Share on other sites

Hi Luke4efc there was a small thin pipe snapped at the joint so i put it back in although a bit shorter it fit, but still get juddering on revving.

does it need resetting at all.

Share this post


Link to post
Share on other sites

1.8 TDCI?  That small pipe is part of the MAP sensor so it needs to be on tight.

I suspect you've split one of the larger pipes if you heard it pop though.

Share this post


Link to post
Share on other sites

thanks for advice will give it a check next weekend with my son (work away all week).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.