Jump to content
Do Not Sell My Personal Information


2016 Titanium Sync 2 - Sync 3 - Updating software after


Recommended Posts

Hi

 

Apologies firstly if this has been asked before search didn't like the sync word being used and didn't help.

 

I have just done an update from sync 2 to sync 3. I just went to check any updates but ford still sees my car as a sync 2. have a few questions :) please note I dont have the donor car VIN.

I am running 3.0 build 19205

NAV f9

1. Is there a newer version ( not 3.4 as know thats not made for the car) if so how do I do it as website/wifi in car says upto date 

2. Is there a way to get the for site to register I now have sync 3? thanks for any help :)

Link to post
Share on other sites

Whoops I misread your post completely lol.

Anyway, you can't update Ford website to say you have Sync 3, you'll have to find a VIN for a car with Sync 3 or get someone to post the zip file for the updates.

Link to post
Share on other sites
1 hour ago, Luke4efc said:

Whoops I misread your post completely lol.

Anyway, you can't update Ford website to say you have Sync 3, you'll have to find a VIN for a car with Sync 3 or get someone to post the zip file for the updates.

thought that maybe the case. will the vin have to match my car, obv not a sync 3.4 or above one - just mean specs or will any do? just so long as sync 3. dont wanna make a mess of it all. thanks 🙂 

Link to post
Share on other sites
6 minutes ago, DaSingh said:

You can upgrade to 3.4 manually using cyanlabs tools

Windows Automated Method - Update to 3.4 - CyanLabs

Plenty of videos on youtube too showing you how.

thanks, does CarPlay etc work ok? or are there any 3.4 bugs to worry about or is it perfectly fine

managed to updated to 3.0 build 20something and all went ok - just car play has swapped for LHD mode 😕 lol

Link to post
Share on other sites

I have a 2016 ST250 ST3, which I upgraded from SYNC 2 to SYNC 3, before Christmas.

SYNC 3 version was:

software version 3.0 Build 19205_Product Navigation maps version: F9

On 8th March I used Cyanlabs Syn3 Updater.

Now have:

SYNC 3, Software Version 3.4 Build 20351_Product Navigation Maps Version: F9

Everything seems to be working OK, including the Logo's for the radio stations. Assume that the F9 will also be a later version of the original F9.

I have an Android mobile, so use Android Auto, which is working fine. No idea on Car Play.

If you find a VIN to use on the Ford website, that is used by someone else that's already updated past your version, it will say you are up to date.

Link to post
Share on other sites
1 hour ago, YOG said:

I have a 2016 ST250 ST3, which I upgraded from SYNC 2 to SYNC 3, before Christmas.

SYNC 3 version was:

software version 3.0 Build 19205_Product Navigation maps version: F9

On 8th March I used Cyanlabs Syn3 Updater.

Now have:

SYNC 3, Software Version 3.4 Build 20351_Product Navigation Maps Version: F9

Everything seems to be working OK, including the Logo's for the radio stations. Assume that the F9 will also be a later version of the original F9.

I have an Android mobile, so use Android Auto, which is working fine. No idea on Car Play.

If you find a VIN to use on the Ford website, that is used by someone else that's already updated past your version, it will say you are up to date.

thanks for the heads up. im tempted to try it, just worried about the car play as that was the point to this lol. 

Link to post
Share on other sites

Everything works great on the new update 3.4 mate Carplay is quick etc,although like yourself it has defaulted to LHD on the screen. Maybe a way through forscan to change it to rhd?

Link to post
Share on other sites
4 hours ago, Marker1971 said:

Everything works great on the new update 3.4 mate Carplay is quick etc,although like yourself it has defaulted to LHD on the screen. Maybe a way through forscan to change it to rhd?

its weird its gone back to RHD now. im gonna do the 3.4 upgrade. it seems pretty simple tbf. follow the boxes make sure all info is correct and let it download. pretty much it in a nutshell.

 

Link to post
Share on other sites

Make sure you do master reset after upgrading to 3.4

Also Carplay works but you might have to change the usb hub as I don't think the original sync2 hub will work. It should be fine for android auto. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership