Jump to content
Do Not Sell My Personal Information

Please help with codes


madman
 Share

Recommended Posts

Hi everyone.

I have focus mk2 and was finding oil in my coolant, I had the oil cooler changed after head gasket tests passed. I have only been using car short trips 

Now I have the red light on my dash and engine systems fault reading and accerlation reduced reading on digital display. I ran forscan on it and found a few codes does anyone know what's all these codes mean and do they reflect on the systems engine fault and acceleration reduced 

RCM U1900-30

ACM P1628-60

GEM None

PCM U0155-61

PCM U0001-E1

PCM U0001-E1

PCM P1000-70

OBDII U0001-P

ABS U2012-A0

ABS U1900-A0

ICU U1900-60

please need your help guys 

Thank you

Link to comment
Share on other sites


32 minutes ago, madman said:

Hi everyone.

I have focus mk2 and was finding oil in my coolant, I had the oil cooler changed after head gasket tests passed. I have only been using car short trips 

Now I have the red light on my dash and engine systems fault reading and accerlation reduced reading on digital display. I ran forscan on it and found a few codes does anyone know what's all these codes mean and do they reflect on the systems engine fault and acceleration reduced 

RCM U1900-30

ACM P1628-60

GEM None

PCM U0155-61

PCM U0001-E1

PCM U0001-E1

PCM P1000-70

OBDII U0001-P

ABS U2012-A0

ABS U1900-A0

ICU U1900-60

please need your help guys 

Thank you

You need to reset the codes. go for a drive and rescan for codes, many (potentially all) of those codes could be historic.

  • Like 2
Link to comment
Share on other sites

I see you have the u1900 code and another u code. These are cab bus loss of connection codes. Both can busses route through the instrument cluster. It may be faulty solder joints within the cluster.

This fault often throws up other spurious fault codes as the modules cannot connect.

if your car hasn’t had the cluster re-soldered, it may be this. Try slapping the dash above the centre of the cluster with the engine running and see if you get a reaction. Doesn’t always show but worth a try.

other wise clear the codes and re read them after the next fault appears as previous .

Link to comment
Share on other sites

I took car for short trip to the shops about mile and half  and got back in the car and wouldn't start. I also notice the immobilizer light flashes crazy, with systems engine fault. 

I had my laptop with me and forscan I reset the codes, taped the dash and got it started. 

What you guys thinking please. 

Link to comment
Share on other sites

Was it the slap dash that brought the system back up?  If so possibly the cluster fault. Check the fault codes again .

about £100 to get the cluster resoldered/reconditioned

Link to comment
Share on other sites


Latest Deals

Ford UK Shop for genuine Ford parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via the club

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...

Forums


News


Membership