Jump to content
Do Not Sell My Personal Information


Power windows and locks do not work on both rear doors


Mauro
 Share

Recommended Posts

Good evening friends, I'm new here and I would really like your help.

I have a 2009 Ford Mondeo zetec and the two rear doors don't work, the windows and locks don't work, even if I manually close the doors they don't lock.

I took a look at the FA 3 and 4 fuses and they all seem to be intact. What could it be in this case, as they are the two rear doors with the same problem.

 

Thanks.

Link to comment
Share on other sites


Have they ever worked in the time you have owned the car ?

Link to comment
Share on other sites

3 hours ago, unofix said:

Have they ever worked in the time you have owned the car ?

No, I bought them without working. I've checked the fuses and disconnected the battery, but it's still dead. neither locks nor windows work, even if I manually close and open the car the locks do not work.

Link to comment
Share on other sites

Just now, Mauro said:

No, I bought them without working. I've checked the fuses and disconnected the battery, but it's still dead. neither locks nor windows work, even if I manually close and open the car the locks do not work.

And there is a light on the dashboard indicating that the tailgate is open.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership