Jump to content
Do Not Sell My Personal Information


Dab doesn't work mk3 non sync titanium x


Morty1977
 Share

Recommended Posts

Anyone any ideas? My dab won't work. It doesn't even give me the Manuel scan button. All I get is a loading circle then it switches to fm. Is there any way to update the non sync firmware? Sony head unit with nav 

Link to comment
Share on other sites


If you have a standard 'DAB' radio then you will be limited as to the stations you can receive in your area.

You really need 'DAB+' for the UK now. It's a bit like when they phased out broadcasting analog TV.

Link to comment
Share on other sites

20 minutes ago, unofix said:

If you have a standard 'DAB' radio then I think you're not going to get it to work. You need 'DAB+' for the UK now. It's a bit like when they stopped broadcasting analog TV.

I pretty much agree with much of what you post, but I have to query this one. Yes, DAB+ is prolific now with many stations now broadcasting on it. However, there are still numerous stations that still continue with standard DAB. Unlike many European countries which simply abolished DAB in favour of DAB+, the UK hasn't dismissed it totally and the 2 x standards are still in use.

I'd wonder if DAB worked in his car then suddenly stopped, indicating some kind of fault, software/aerial, or, if he has just got the car and it's never worked for him?

  • Thanks 1
Link to comment
Share on other sites

Thanks for your info Stephen. I had just amended my post when you responded.

Yes he should still get all the main BBC stations for sure. Perhaps he has a fault with the DAB aerial pre-amp which is quite common.

  • Like 1
Link to comment
Share on other sites

24 minutes ago, StephenFord said:

I pretty much agree with much of what you post, but I have to query this one. Yes, DAB+ is prolific now with many stations now broadcasting on it. However, there are still numerous stations that still continue with standard DAB. Unlike many European countries which simply abolished DAB in favour of DAB+, the UK hasn't dismissed it totally and the 2 x standards are still in use.

I'd wonder if DAB worked in his car then suddenly stopped, indicating some kind of fault, software/aerial, or, if he has just got the car and it's never worked for him?

It's never worked had it a year now

Link to comment
Share on other sites


Tried aerial says DAB on it. Had radio out everything connected. Is there some module in the rear of the car that I could check? Sure I've read it somewhere?

Link to comment
Share on other sites

It is the aerial pre-amp which causes a lot of problems.

Every model seems to hide them in a different place but on the ones I've check the Focus seems to have them mounted in the tailgate behind the trim near the top edge (near the hinges). There is quite often two pre-amps, one is for the DAB and the other for SatNav ?

The DAB usually uses the heated rear window as the aerial hence the location of the pre-amp.

Link to comment
Share on other sites

23 minutes ago, unofix said:

It is the aerial pre-amp which causes a lot of problems.

Every model seems to hide them in a different place but on the ones I've check the Focus seems to have them mounted in the tailgate behind the trim near the top edge (near the hinges). There is quite often two pre-amps, one is for the DAB and the other for SatNav ?

The DAB usually uses the heated rear window as the aerial hence the location of the pre-amp.

Thanks I'll check that next👍

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership