Jump to content
Do Not Sell My Personal Information


Urgent Help Required Please!


Markno1
 Share

Recommended Posts

Hi all...

Im new to the forum and having a problem with my 2.0tdci 140 59plate. The problem only happens when towing a trailer/caravan but seems to drive fine the rest of the time. The problem I the car judders or hunts quite violently through most of the rev range in most gears. There are no warning lights too. Regards Mark.

Link to comment
Share on other sites

have you done an onboard diagnostic check?to see if there is any error codes logged.

take a look on 'ford etis' to see if your car has missed any recalls.

i do believe there may well be an update on the ecu to make your car run better.

you may have to ring fords and ask.

Link to comment
Share on other sites

Thanks for the reply. I haven't done a diagnostic check as yet and there are no updates showing on etis (well that its showing me anyway)

Link to comment
Share on other sites

Just a thought would a worn out dual mass flywheel cause the issue Im having by any chance. The cars done 77k and never had a clutch as far as im aware.

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership