Jump to content
Do Not Sell My Personal Information


Dashboard LCD pixels border problem


caion
 Share

Recommended Posts

Hi Guys,

I'm having a problem with my dashboard's LCD. It happens sometimes when I unlock the car and the dashboard LCD light up.
In the beginning (months ago), I used the have the problem when the car was under sunlight for a few hours. I live in Brazil, so the temperature inside the car easily gets to 50º+ celsius. Now, I'm having the problem even when the car is in my garage over the night.
To explain better, I attached a picture.

The instrument cluster and the trip computer works fine.
Recently, the dashboard LCD texts started to dim as the car moves and vibrates. When I give a gentle tap around the LCD (on the silver part of the instrument cluster), the LCD texts brightness comes back to normal. These pixels border stays there until the LCD sleeps (after I lock the car and wait for around 10 minutes, for example).
When I make the LCD light up again, 1 of 2 things may happen: Either the LCD comes back to normal (with no pixels border), or the pixels border comes back differently.
I searched all over Focus forums and haven't found anyone with a similar problem. I wonder if it may be a LCD problem or a bad connected cable. I'm thinking on getting the instrument cluster off, firmly connect it again, and install the cluster back on.
Any ideas, please? I'm starting to get desperated, since every electronical repair here in Brazil costs more than the car worth.
Thanks in advance!

IMG_5350_1.jpg

Link to comment
Share on other sites

looks like you have the standard ford cluster fault the easiest solution os have it tested and repaired if you got another cluster you would need to get it reprogrammed to the car or it wont start you can ensure its firmly plugged in at the rear but it sounds like a cluster fault in afraid.if it gets worse you may end up where you cant even start the car

Link to comment
Share on other sites

On 15/02/2016 at 4:32 PM, mrmetallica said:

i had a problem with mine not showing properly.i took the glass part from anothe speedo and it worked ok.before i found out how to reprograme new clocks that is .

So even if I change the display only, will I have to reprogram it to my car?

Link to comment
Share on other sites

21 minutes ago, caion said:

So even if I change the display only, will I have to reprogram it to my car?

no you wont have to reprograme .just change the lcd class.not gaurantee it will work but worked for me.

Link to comment
Share on other sites


4 hours ago, mrmetallica said:

no you wont have to reprograme .just change the lcd class.not gaurantee it will work but worked for me.

Alright!

Was thinking about that. I may buy an used instrument cluster and take its display off.

Thansk for the tip.

Link to comment
Share on other sites

19 hours ago, caion said:

Alright!

Was thinking about that. I may buy an used instrument cluster and take its display off.

Thansk for the tip.

make sure its the same one as yours.other wise wont fit

Link to comment
Share on other sites

  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership