Sign in to follow this  
ashy401

Black smoke

Recommended Posts

hi i recently purchased a mondeo 130bhp mk3 estate 06 reg.

the problem i have with it is every time i accelerate i get a cloud of black smoke behind me just before the turbo kick in than it clears. also if i slow down then accelerate in same gear i puts out loads of black smoke and takes a while for speed to increase then turbo kicks in and it clears.

currently i have check the following

cleaned and check inlet manifold, Egr valve, All air pipe from turbo to Egr valve, the injector code have been read with super and are the same as what is stated on each injector. turbo actuator arm moves freely to both extremes.

yesterday i disconnected the MAF sensor and there was no change to idle.

i am stuck for what to check next.

any help will be appreciated. thanks

 

Share this post


Link to post
Share on other sites

hi thanks for the fast reply. it was only left at idle. will the MAF be the same on both the 115 and 130 bhp version if so i can take it off my other mondeo and try it tomorrow.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this