Sign in to follow this  
Mike6167

Mk 3 Mondeo 1.8 petrol, issue with engine idle

Recommended Posts

Hello, I'm hoping someone will be able to help me with a little problem.  I have a 54 plate 1.8 petrol which drives fine except when I slow down in traffic or at lights etc, just as the car comes to a stop the revs will rise to 1500 rpm, hold there for a couple of seconds then jump to 2000 rpm for a second and then drop back to normal.  It does it every time I come to a stop and it's always exactly the same, up to 1500 rpm then to 2000 then back to normal. I'm wondering if it's a sensor issue as it also seems to happen just as the car drops under 5 mph and my thinking is that some sensor or combination of sensors is giving the ecu false data and this is causing the problem.  I'm not certain though and even if it is a sensor, I'm not sure which one(s) might be causing it so would appreciate any advice on this.   Thanks guys:smile:

Share this post


Link to post
Share on other sites

Hi, Check throttle body.I had the same issue turned out to be an issue with the Gearbox and engine ratio.

Also do computer diagnostics and see if you pick up any fault codes.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this