Sign in to follow this  
transittony

Turbo or split hose?

Recommended Posts

Hi all….!    Brand new newby here, asking about a problem I have with my 2010 Mondeo Estate 1.8 TDCI.    On acceleration, just as the turbo kicks in at about 2000rpm, there is a low noise – like a wooo .  The pitch does not increase with the engine speed.  I have managed to record and upload the noise it makes here:   https://youtu.be/zJv3o48Dv74   Is that the turbo or maybe a hose split, do you think.?   Thanks for any help offered.

Share this post


Link to post
Share on other sites

... forgot to mention ....no loss of power, no other symptoms or any Engine Management lights on.

Share this post


Link to post
Share on other sites

Another way of finding out if it is the hose is black smoke coming out the back on hard acceleration. Mine's started with this wooshing noise but it's really loud, does my head in. I was told to check the Fuel filter and the Turbo hose. filter will cost you £15 max and the hose for a silicone one will set you back about £35.

Share this post


Link to post
Share on other sites

The little 90 degree pipe at the rear left of the engine is prone to splitting on the underside.

If you can get someone to rev your engine to around 2.5K RPM whilst you run your hands around the pipes, if there is even a small split you should be able to feel it due to the air escaping.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this