Sign in to follow this  
Kiosk Keith

MK4 Diesel dead after fuel pump change

Recommended Posts

Hello again everyone.

 

The saga continues............................

 

My tech eventually diagnosed an ongoing starting problem to be down to the high pressure fuel pump. He run a pressure test on it and the initial pressure was 350PSI which suddenly drops to 140PSI until it finally starts then runs at a constant pressure. There is also evidence of fuel leakage in the area of the HPFP on its cover.

 

So...................... got another Delphi pump for it which was fitted today but now shes dead. After replacing the HPFP the car started but then began to idle roughly before stalling. Since then it reuses to start, even after towing her and trying to bump start her.

 

He said its showing a fault that relates to underboost?

 

The car has recently had a full service with all filters changed, I also had the fuel system checked for air leaks at the same time which came back fine.

 

In brief, HELP!!!!!!!!!!!!!!!!!!!!!!!!!

 

Chris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this