Sign in to follow this  
riceman1964

Mondeo Petrol Auto Accelerator Problem

Recommended Posts

Hi i have a mondeo 2l petrol auto, i drove from the midlands to great yarmouth, on the way the car drove fine but on the way back after travelling for about 2 hours i went to over take and noticed as i put my foot down there was no kick down and as the revs reached 4000 it would not rev any higher, the car then played up all the way home kept losing power, left the car overnight still no change, with the car in park it ticks over fine but press accelerator it wont go above 4000 revs.

Any ideas cheers riceman1964

Share this post


Link to post
Share on other sites

Any warning lights? As Dezwez says, check for codes, sounds like it could possibly be limp home mode

Sent via the 'Clacks'

GNU STP

Share this post


Link to post
Share on other sites

HI thanks for replies but the engine management light is not on.

cheers riceman1964

Share this post


Link to post
Share on other sites

Hi i now have an electrical problem here goes - when i release the boot either with the key or on the dash the rear reg plate lights come on but the reg plate lights do not come on with the lights, when i put the lights on everything seems to work fine except the reg plate lights and the light comes on the dash which says there is a door open???? any ideas riceman1964

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this