Jump to content
Do Not Sell My Personal Information



Recommended Posts

I had a similar problem with my 2014 Titx. No radio! in fact No audio at all!. It appeared to have 'crashed' completely. It would not even respond to the 'Radio' display selection button. Using the Converse controls I could select Radio but changing stations did nothing other than affect the Converse display, It was stuck on the DAB band though. Everything other than Radio/Audio worked fine. NAV, Climate,Phone etc albeit No audio from any of them!.

I pulled the fuse for the Audio/BT (F43 in the Engine compartment), reinserted it and it worked again fine

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...