Jump to content
Do Not Sell My Personal Information


Help!!! Aftermarket Stereo not working with stalk control


Thatguycraig
 Share

Recommended Posts

Focus 2010 mk2.5

Got a Kenwood single din stereo. The steering wheel control is a single wire.

Bought the pc99-x50 plus the pc99-ken patchlead 

All plugged in. Powered fine. Radio signal fine. Stalk controls.. Not fine

 

Done the usual, tried storing a station first, no luck, tried powering it on without the patch lead in first... No luck

Stalk control does diddly squat 

Ideas please?!

FYI in the power block behind the radio, at the bottom of the block there are two small blocks. One with a white end one black. The white has purple and purple/white wires. The black had brown and brown/white. The patch lead had brown and brown white and correct pin configuration. Is this the right one??? I presume it is but just winding what the purple wires are? 

 

Thanks

Link to comment
Share on other sites


I did have a similar problem with my MK1.5 Focus and realised I had managed to blow the converter box, it was connected with a jack plug that while unplugged shorted to something.  I just had to replace it.

Link to comment
Share on other sites

Reading about the  pc99-x50

 

Quote

Ford Steering Wheel Adaptor suitable for following Vehicles:

  • Ford Focus    (Jan 2005 to Feb 2007) 
  • Ford C-Max   (Sep 2003 to March 2006)
  • Ford Mondeo (Nov 2003 to Feb 2007)

 

 

Make sure you have connected any additional power wires which may be required by your adapter. I used the  CTSFO002 adaptor for mine (£25, comes with the appropriate patch lead).

Check that all the wires that connect to the unit from the Fakra connector are populated on your vehicles side - I don't know if they changed wire positions or resistor values inside the stalk controls between the years.

The purple wires are probably for the illumination circuit, which isn't used with most aftermarket systems.

Link to comment
Share on other sites

hey - I bought a replacement pc99 and its working. The box was clearly stuffed on the first one! So thank you thus far for all replies. 

For anyone else who gets one of these, those are the things to check:

first that the purple wires and the brown wires are in the correct position on the adapter lead to the quadlock in the car - the first wasnt, and even though it didnt resolve my problem, it would have never have worked even if the box wasnt broken! You can unclip these though (at least you could on mine, and it was an autoleads one)

Secondly - when all else fails - ask for a replacement!! Seemed like a cop out, but i didnt know what else to test. 

 

And for anyone interested in what I did, in regards to the 'pattern' in which to plug in -

  • Plugged in quadlock, stalk adapter to quad lock, adapter to headunit wi,re but left the 2 pin power lead out of the stalk adapter box.
  • Turned on engine to see stereo worked. 
  • turned off engine, plugged in 2 pin power to adapter.
  • turned engine back on - hey presto! 

dont know if these steps did any sort of difference, but i wasnt taking chances this time! 

Now to decide if i want to upgrade the head unit to a double din :/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership