Jump to content


Show
Photo
- - - - -

All Brake Lights Don't Work


  • Please log in to reply
2 replies to this topic

#1 ceri hurlow

ceri hurlow

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: fiesta

Posted 11 September 2010 - 05:45 PM

Hi All,

Im a new meber so hi to all. Hope you guys can help me with a little (big) problem on my Fiesta MK 6. my brake lights (all three) have stopped working completely and i cant figure it out. I have swapped out the brake switch (even connected a wire directly to test), checked fuses and changed bulbs but nothing. When i put a meter on the green black lead which i think is the left hand brake light there is no voltage when the brake is on. I have even removed the fuse box but tracing the wire back to the fuse is a nightmare. I hope one of you Fiesta Gurus can help as i am tearing my hair out (no actually i'm bald :P ) and everybody else that has had a look is also confused). Spent about 8 hrs on this so far. All other lights inc tail lights work gr8.

Many Thanks

Ceri

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 tommy.h

tommy.h

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 251 posts
  • Name: tom
  • Ford Model: mondeo 2.0 diesel mk4
  • Year: 2007
  • Location: Cheshire

Posted 11 September 2010 - 07:32 PM

Hi Ceri

i have sent a pm if you get in touch i will send you the wiring diagrams(i do not know how to attach on this thread)
i did it yesterday but for some reason it is not there today.

tom

Hi All,

Im a new meber so hi to all. Hope you guys can help me with a little (big) problem on my Fiesta MK 6. my brake lights (all three) have stopped working completely and i cant figure it out. I have swapped out the brake switch (even connected a wire directly to test), checked fuses and changed bulbs but nothing. When i put a meter on the green black lead which i think is the left hand brake light there is no voltage when the brake is on. I have even removed the fuse box but tracing the wire back to the fuse is a nightmare. I hope one of you Fiesta Gurus can help as i am tearing my hair out (no actually i'm bald :P ) and everybody else that has had a look is also confused). Spent about 8 hrs on this so far. All other lights inc tail lights work gr8.

Many Thanks

Ceri



#3 ceri hurlow

ceri hurlow

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: fiesta

Posted 12 September 2010 - 08:52 AM

Hi Tom,

I have e-mailed you. Thanks again for the help mate

Ceri :rolleyes:


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users